• Welcome to the Pontiac Trans Am Community, the Official Home of the PTA! Sign up for a (FREE) account today!

Turning Signal Issues - 2001 TA WS6

jbmatthews2001

New member
Joined
Sep 23, 2022
Messages
1
Reaction score
1
Points
1
Location
Wv
I recently bought a 2001 TA WS6 as a project for my son.

Initially, the drive turning signals worked; they just flashed super slow.

Passengers' sides stay solid.

I went out today to replace the low beam headlight on the passenger side and noticed that both driver and passenger side turning signals were staying solid.

I did some digging and saw where the flasher relay could be an issue, so I pulled the knee panel off and saw that the harness was taped up, and after wiggling it around, the driver's side started working again.

From what I can tell, there are only two wires.
 
  • Like
Reactions: Knightrider189

Onyx

Member
Joined
Mar 15, 2024
Messages
4
Reaction score
8
Points
3
Location
springfield, il
My 97 has turn signal issues, too.

I got the car, and the turn signals didn't work.

The dash indicator barely lights up when the switch is switched.

I replaced the flasher, but it didn't help, so I installed a new turn signal switch to the column.

I got nothing until i cycled the headlights, and now it has a right-side turn signal but no left.

All bulbs are good, the switch is new, the flasher is new.

Does anyone have any ideas on where to look next?
 

Onyx

Member
Joined
Mar 15, 2024
Messages
4
Reaction score
8
Points
3
Location
springfield, il
roblem solved!

This was the problem.

IMG_20240502_084019.jpg
 

Knightrider189

Well-known member
Joined
Dec 26, 2018
Messages
132
Reaction score
129
Points
43
Ah, someone put LEDS.

Glad you figured it out.


1989 Pontiac Formula Firebird, 5.7, all OEM
 
  • Like
Reactions: Onyx